ShoreTel and VLANS (So you want to run your Phones and Computers on the same physical network?)

Uncategorized

ShoreTel and VLANS (So you want to run your Phones and Computers on the same physical network?)

by Charlie Lingerfelt

For customers that do not have dedicated networks for their VOIP Phones (Shoretel in this case), I have created a Dell Configuration that we can reuse.

In Layman’s terms this VLAN config will allow computers to be plugged into the Shoretel Phones, utilizing only one Ethernet Jack per Phone/Computer Combination instead of having to run 2 cables for phone and computer.

Assumptions
ShoreTel phone system, Windows DHCP server (Although a Unix will work, as long as your can specify special parameters), and Dell Switching or equivalent

Potential Benefits:
–    Reduced infrastructure costs to implementing a VOIP phone system for existing companies that already have existing quality network wiring. (CAT5, CAT5E OR CAT6)
Potential Drawbacks:
–    Additional Complexity in initial setup
–    Most Shoretel Phones are only 100Mb/s limiting workstation data speeds. New Phones are designated with the “G” at the end of them which support Gigabit networking speeds.  For example the IP230G from ShoreTel.

VLAN Info
The default VLAN for the switch in this example is used for Data is VLAN1.  VLAN 2 is used for Voice Traffic.  The uplink ports for this switch that connect to another Mult-VLAN switch are set to trunk mode to allow that port to see and forward all VLANs to the remote switch.  I configured non-uplink ports to utilize VLAN1 at boot.  If the device is a Shoretel Phone, it will boot utilizing DHCP and the reboot again and request VLAN2 assignment. This is handled by having extended information in the DHCP server.

DHCP Info
DHCP Scope Options:  (n.n.n.n is the IP Address of the FTP server that hosts the Shoretel Phone Software)

155    Shoretel FTP Server        n.n.n.n
156    Shoretel IP Phones        ftpservers=n.n.n.n,  country=1, language=1, layer2tagging=1, vlanid=2

Note about PortFast
Note for the Shoretel Phones to boot immediately, we must enable port-fast rather than the default Spanning-Tree setup. Otherwise the phones will not appear to get DHCP at boot.

Example Config
3548P after running its wizard and giving it an IP Address, Subnet Mask, Gateway, and other info.

interface range ethernet e(1-48)
spanning-tree portfast
exit
interface range ethernet e(1-48)
switchport mode general
exit
interface range ethernet g(1-4)
switchport mode trunk
exit
vlan database
vlan 2
exit
interface range ethernet e(1-48)
switchport general allowed vlan add 2
exit
interface range ethernet g(1-4)
switchport trunk allowed vlan add 2
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________

console# show running-config
interface range ethernet e(1-48)
spanning-tree portfast
exit
interface range ethernet e(1-48)
switchport mode general
exit
interface range ethernet g(1-4)
switchport mode trunk
exit
vlan database
vlan 2
exit
interface range ethernet e(1-48)
switchport general allowed vlan add 2
exit
interface range ethernet g(3-4)
switchport trunk allowed vlan add 2
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
interface vlan 1
ip address 192.168.5.250 255.255.255.0
exit
interface vlan 2
ip address 192.168.4.250 255.255.255.0
exit
ip default-gateway 192.168.5.1
username admin password nnnnnnnnnnnn level 15 encrypted
snmp-server community Dell_Network_Manager rw 192.168.5.250 view DefaultSuper
Default settings:

Fast Ethernet Ports
==========================
no shutdown
speed 100
duplex full
negotiation
flow-control off
mdix auto
no back-pressure

Gigabit Ethernet Ports
=============================
no shutdown
speed 1000
duplex full
negotiation
flow-control off
mdix auto
no back-pressure

interface vlan 1
interface port-channel 1 – 15

spanning-tree
spanning-tree mode STP
qos basic

If you have a 6224P that you are configuring, here are the quick changes to designate its VLAN info.

=======================
Alternative Config for 6224P

interface range ethernet 1/g1-1/g20
spanning-tree portfast
switchport mode general
exit
interface range ethernet 1/g21-1/g24
switchport mode trunk
exit
vlan database
vlan 2
exit
interface range ethernet 1/g1-1/g20
switchport general allowed vlan add 1-2
exit
interface range ethernet 1/g21-1/g24
switchport trunk allowed vlan add 1-2
exit

 

 

——–

 

If there are better options, please comments so I can update best practices.

Thanks!

Charley

 

More About the Author

Charlie Lingerfelt

Senior Consultant
Remote Building Wireless Connectivity Kit Do you have a site that is just out of reach of your physical network? Maybe a remote warehouse across a field, or maybe two building ...
Hyper-V Manageability Just a reminder, if you plan to run Hyper-V for production use, you should definitely run the System Center tools to manage your ...

See more from this author →

Subscribe to our newsletter

  • I understand that InterWorks will use the data provided for the purpose of communication and the administration my request. InterWorks will never disclose or sell any personal data except where required to do so by law. Finally, I understand that future communications related topics and events may be sent from InterWorks, but I can opt-out at any time.
  • This field is for validation purposes and should be left unchanged.

InterWorks uses cookies to allow us to better understand how the site is used. By continuing to use this site, you consent to this policy. Review Policy OK

×

Interworks GmbH
Ratinger Straße 9
40213 Düsseldorf
Germany
Geschäftsführer: Mel Stephenson

Kontaktaufnahme: markus@interworks.eu
Telefon: +49 (0)211 5408 5301

Amtsgericht Düsseldorf HRB 79752
UstldNr: DE 313 353 072